Issues with update

Page 1 of 2 1, 2  Next

View previous topic View next topic Go down

Issues with update

Post  Jdudeo on Sat Jun 22, 2013 11:11 pm

I've recently received the latest update of the DAWOSC Android app and downloaded the new pd patch, the new editor and saved my old layouts in the new format, I'm having a problem though getting my buttons to work properly.

Faders appear to work fine as they did before but when I use any buttons in my interface it seems to be reversing the CC and value fields, so for example I have a button that's supposed to send a value of 127 as CC 3 when on and a value of 0 when off. What happens is when it's on it sends a value of 3 as CC 127 and when off sends a value of 3 as CC 0.

I thought changing connections in the pd patch might fix this but for some reason it didn't and even if it did it would logically mess up the faders which are working fine.

Is anybody else experiencing this?

Jdudeo

Posts : 40
Join date : 2013-05-18

View user profile

Back to top Go down

Re: Issues with update

Post  Jdudeo on Sat Jun 22, 2013 11:47 pm

Apart from that I'm loving the new look!

Jdudeo

Posts : 40
Join date : 2013-05-18

View user profile

Back to top Go down

Re: Issues with update

Post  Admin on Sun Jun 23, 2013 8:10 am

oops...I know what the problem is. I'll have that fixed in a few hours. I'll post here when it's fixed. Sorry about that!

Mark

Admin
Admin

Posts : 384
Join date : 2012-11-17

View user profile http://dawosc.forumotion.com

Back to top Go down

Re: Issues with update

Post  Jdudeo on Sun Jun 23, 2013 8:15 am

No problem, by the way I've really come to love this app since adopting use of it about a month ago, it's now an indispensable part of my setup and can't imagine life without it.

Jdudeo

Posts : 40
Join date : 2013-05-18

View user profile

Back to top Go down

Re: Issues with update

Post  Admin on Sun Jun 23, 2013 8:39 am

Jdudeo wrote:No problem, by the way I've really come to love this app since adopting use of it about a month ago, it's now an indispensable part of my setup and can't imagine life without it.
Awesome! Glad to hear that!

And the button issue is fixed. It'll take Google Play anywhere from 1-2 hours to update. If you're still having problem, just post here and I'll get to it as soon as I can Smile

Mark

Admin
Admin

Posts : 384
Join date : 2012-11-17

View user profile http://dawosc.forumotion.com

Back to top Go down

Re: Issues with update

Post  Jdudeo on Mon Jun 24, 2013 7:41 am

Thanks. I'm now having a problem with connection though, doing everything the same way as before it just doesn't connect to pd, double checked IP address and such, any ideas?

Jdudeo

Posts : 40
Join date : 2013-05-18

View user profile

Back to top Go down

Re: Issues with update

Post  Admin on Mon Jun 24, 2013 8:38 am

Hmmm...that's strange...

These are probably really stupid questions, but...
you're using the latest pure data patch file?
you're starting pure data and opening the pure data patch file BEFORE starting dawosc?

I'm also probably releasing a new version tonight or tomorrow, so maybe the new version will fix your problem.

if the answer to both questions is 'yes', let me know and I'll look into it when I get home tonight.

Admin
Admin

Posts : 384
Join date : 2012-11-17

View user profile http://dawosc.forumotion.com

Back to top Go down

Re: Issues with update

Post  Jdudeo on Mon Jun 24, 2013 9:29 am

That's right I did everything the same as before and made sure to use the new pd file, anyway I'll try it again tomorrow maybe I'll have better luck

Jdudeo

Posts : 40
Join date : 2013-05-18

View user profile

Back to top Go down

Re: Issues with update

Post  Admin on Mon Jun 24, 2013 9:44 am

ok, I'll check it out tonight after work.

Admin
Admin

Posts : 384
Join date : 2012-11-17

View user profile http://dawosc.forumotion.com

Back to top Go down

Re: Issues with update

Post  Admin on Tue Jun 25, 2013 5:59 am

I wasn't able to duplicate it, but maybe the new release I did last night will fix your problem. Let me know if it's still not working.

Admin
Admin

Posts : 384
Join date : 2012-11-17

View user profile http://dawosc.forumotion.com

Back to top Go down

Re: Issues with update

Post  Jdudeo on Tue Jun 25, 2013 7:07 am

Well I've managed to get it to work, I think maybe the problem was that pd was still loading the old patch at startup and even if I closed that patch and loaded the new one, the fact it loaded the old one first trumped the connection to the new one somewhere? Anyway thanks for the help and the buttons are now working correctly also!

Jdudeo

Posts : 40
Join date : 2013-05-18

View user profile

Back to top Go down

Re: Issues with update

Post  Admin on Tue Jun 25, 2013 8:16 am

Ahhh...that explains it. Yeah, I hate it when PD loads more than one patch file at the same time...then nothing works.

I can't wait to buy a Mac so I can get rid of puredata and write my own client software for PCs and Macs Smile

Admin
Admin

Posts : 384
Join date : 2012-11-17

View user profile http://dawosc.forumotion.com

Back to top Go down

Re: Issues with update

Post  Jdudeo on Wed Jun 26, 2013 12:17 am

yeah client software would be cool too, I'm guessing easier to update also

By the way one thing I've noticed about the app is that when I switch to another app or the home screen, then back to the app, all the controllers are reset to default values. If there was some way to fix this it would be a big help. At the moment I'm building a patch in Max/MSP that when triggered will send out all mapped values from Ableton to the app and update all the controllers with their real values but it seems like there should be some fix possible on the app side.

Jdudeo

Posts : 40
Join date : 2013-05-18

View user profile

Back to top Go down

Re: Issues with update

Post  Admin on Wed Jun 26, 2013 6:51 am

Oops! I completely forgot about that! Thanks for reminding me Smile I've been meaning to fix that for a long time.

I'm release a new version tomorrow, so I'll fix that for tomorrow's release.

thanks!

Admin
Admin

Posts : 384
Join date : 2012-11-17

View user profile http://dawosc.forumotion.com

Back to top Go down

Re: Issues with update

Post  Jdudeo on Wed Jun 26, 2013 8:23 pm

Excellent!

Jdudeo

Posts : 40
Join date : 2013-05-18

View user profile

Back to top Go down

Re: Issues with update

Post  Jdudeo on Fri Jun 28, 2013 12:44 am

I was just thinking, would it be possible maybe as a long term goal to incorporate a function of the DAWOSC app loading its preset files from the computer it's connecting to at loading time? Maybe the pd patch can specify where the files are or some path can be saved in the app which it accesses via TCP/UDP like it does for MIDI and OSC data?

I was just thinking about this because I find myself modifying my presets a lot, and every time I have a new version I find myself having to transfer it to my device and then specify the new version in the app, not all that time consuming but it builds up after a while, though maybe there's a solution with some shared directory like dropbox where the old preset file can just be overridden...

Jdudeo

Posts : 40
Join date : 2013-05-18

View user profile

Back to top Go down

Re: Issues with update

Post  Jdudeo on Fri Jun 28, 2013 12:53 am

Ah my bad I just saw this in the Feature Requests section:

"Editor:
editor: ability to save layouts directly to your Android device"

Jdudeo

Posts : 40
Join date : 2013-05-18

View user profile

Back to top Go down

No connection

Post  Jdudeo on Mon Jul 08, 2013 7:51 am

Since tonight I'm not getting any connection between the app and pd, it was working fine yesterday, but I seem to remember seeing that the app was recently updated? I've tried everything but no luck, I get no message in pd when I boot up the app on my Nexus 7, any clues?

Jdudeo

Posts : 40
Join date : 2013-05-18

View user profile

Back to top Go down

Re: Issues with update

Post  Jdudeo on Mon Jul 08, 2013 7:53 am

By the way, it would be cool to get a message in the app when opened after an update, that said what's been changed, when it was updated and if downloading a new pd patch or version of the editor is required. The updates section of the forum hasn't been updated since May.

Jdudeo

Posts : 40
Join date : 2013-05-18

View user profile

Back to top Go down

Re: Issues with update

Post  Admin on Mon Jul 08, 2013 12:21 pm

The reason I haven't updated the forum with all the updates lately is because I simply haven't had time. We just moved into a new house a few weeks ago, so that's been taking up all my time. Things are SLOWLY getting back to normal, so I'll be able to update the forum more regularly Smile And I'll put an update screen in the app later on.

And I'll look into your connection issue? Has anything changed at all at your end? Make sure you have the latest PD patch file too.

Admin
Admin

Posts : 384
Join date : 2012-11-17

View user profile http://dawosc.forumotion.com

Back to top Go down

Re: Issues with update

Post  Jdudeo on Mon Jul 08, 2013 6:48 pm

Thanks, don't worry about the update issue, I realized that my computer had automatically changed its IP address for some reason and just had to update the app, sorry for the false alarm...

Jdudeo

Posts : 40
Join date : 2013-05-18

View user profile

Back to top Go down

Re: Issues with update

Post  Jdudeo on Mon Jul 08, 2013 8:13 pm

I understand you're busy with other stuff and appreciate everything you do for this app and the users

Jdudeo

Posts : 40
Join date : 2013-05-18

View user profile

Back to top Go down

Re: Issues with update

Post  Admin on Mon Jul 08, 2013 9:11 pm

Jdudeo wrote:Thanks, don't worry about the update issue, I realized that my computer had automatically changed its IP address for some reason and just had to update the app, sorry for the false alarm...

Ahh...of course! I hate it when that happens!

Admin
Admin

Posts : 384
Join date : 2012-11-17

View user profile http://dawosc.forumotion.com

Back to top Go down

Re: Issues with update

Post  Admin on Mon Jul 08, 2013 9:15 pm

Jdudeo wrote:I understand you're busy with other stuff and appreciate everything you do for this app and the users

I appreciate that Smile You made me realize something though...if you set up DAWOSC to auto-update, you never see the "what's new" message from google play. So I'll implement a 'what's new" in the app for the next release Smile

Thanks!

Admin
Admin

Posts : 384
Join date : 2012-11-17

View user profile http://dawosc.forumotion.com

Back to top Go down

Re: Issues with update

Post  Jdudeo on Mon Jul 08, 2013 11:37 pm

Excellent thanks!

Jdudeo

Posts : 40
Join date : 2013-05-18

View user profile

Back to top Go down

Re: Issues with update

Post  Sponsored content


Sponsored content


Back to top Go down

Page 1 of 2 1, 2  Next

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum