Editor crashing at launch

View previous topic View next topic Go down

Editor crashing at launch

Post  Llamatron on Sat Aug 10, 2013 2:56 pm

Hello, I run Windows 7 x64 and the latest editor won't even start for me (the previous one was doing the same), I just get the message from windows telling me the program crashed. Is there logs somewhere which could help indicate what causes this crash?

Llamatron

Posts : 10
Join date : 2013-08-10

View user profile

Back to top Go down

Re: Editor crashing at launch

Post  Admin on Sat Aug 10, 2013 6:11 pm

No, there isn't a log file that is made by the editor.

try this:

- un-install the app
- right-click on the editor setup program and select "Run as Administrator".

What the problem most likely is that some support files aren't being set up properly, possibly due to improper permissions.

Let me know if that doesn't help.

Mark

Admin
Admin

Posts : 384
Join date : 2012-11-17

View user profile http://dawosc.forumotion.com

Back to top Go down

Re: Editor crashing at launch

Post  Llamatron on Sun Aug 11, 2013 1:38 am

No that didn't help, tried with admin rights and antivirus (avast) disabled.

If it can be of any help, it removes 9 ocx files from system32 when uninstalling.

Llamatron

Posts : 10
Join date : 2013-08-10

View user profile

Back to top Go down

Re: Editor crashing at launch

Post  Admin on Sun Aug 11, 2013 7:52 am

I created a new installer for you to try. You can download it at:

http://markderrico.com/installer/

Hopefully, this will work Smile

Mark

Admin
Admin

Posts : 384
Join date : 2012-11-17

View user profile http://dawosc.forumotion.com

Back to top Go down

Re: Editor crashing at launch

Post  Llamatron on Sun Aug 11, 2013 8:21 am

Nop this still does the same thing Sad Is there dependencies like .NET or such?

Llamatron

Posts : 10
Join date : 2013-08-10

View user profile

Back to top Go down

Re: Editor crashing at launch

Post  Admin on Sun Aug 11, 2013 8:33 am

Nope, it doesn't have any special .NET requirements.

It installs on all my Win7 64 machines here and also the beta-testers' machines. I haven't heard of anyone else having this problem.

Try installing it to c:\dawosc and then delete all the files that have the extension "lst".

Admin
Admin

Posts : 384
Join date : 2012-11-17

View user profile http://dawosc.forumotion.com

Back to top Go down

Re: Editor crashing at launch

Post  Llamatron on Sun Aug 11, 2013 8:48 am

Still no joy. Ya I figure it's pretty weird as I seem to be the only one affected by this. If it is of any help the exception code shown in Window's applications log is 0xc000041d

Llamatron

Posts : 10
Join date : 2013-08-10

View user profile

Back to top Go down

Re: Editor crashing at launch

Post  Admin on Sun Aug 11, 2013 9:03 am

That error code helped (I hope!) plus the fact that you said that the last editor update didn't run either.

I created a new editor that has all networking code removed, so you won't be able to send a layout to your device, but it'll help figure this problem out.

You can download the editor program at:

http://markderrico.com/installer/

Just copy the exe to the directory where you installed it (overwrite the existing exe) and try it.

Admin
Admin

Posts : 384
Join date : 2012-11-17

View user profile http://dawosc.forumotion.com

Back to top Go down

Re: Editor crashing at launch

Post  Llamatron on Sun Aug 11, 2013 9:15 am

It still doesn't work, with the same exception code in Window's log.

Llamatron

Posts : 10
Join date : 2013-08-10

View user profile

Back to top Go down

Re: Editor crashing at launch

Post  Admin on Sun Aug 11, 2013 9:45 am

I uploaded two new EXE's. Give them a try to see if they open. The exe with "test" in it won't work, so don't try to actually use it!

Admin
Admin

Posts : 384
Join date : 2012-11-17

View user profile http://dawosc.forumotion.com

Back to top Go down

Re: Editor crashing at launch

Post  Llamatron on Sun Aug 11, 2013 9:54 am

Still no luck with the first .exe. I'm unsure if I understood well about the "test" one, should I rename it to try it or not try at all? (in which case it's only one exe to test)

Llamatron

Posts : 10
Join date : 2013-08-10

View user profile

Back to top Go down

Re: Editor crashing at launch

Post  Admin on Sun Aug 11, 2013 9:58 am

Sorry, I meant try the "test" one, but it if it does actually run, don't use it to create layouts. It's just a test version.

Admin
Admin

Posts : 384
Join date : 2012-11-17

View user profile http://dawosc.forumotion.com

Back to top Go down

Re: Editor crashing at launch

Post  Llamatron on Sun Aug 11, 2013 10:02 am

Still the same Sad thanks for spending the time to pin this issue, I'm starting more and more to think there's something conflicting on my system, what possible candidate would there be apart from the antivirus/firewall?

Llamatron

Posts : 10
Join date : 2013-08-10

View user profile

Back to top Go down

Re: Editor crashing at launch

Post  Admin on Sun Aug 11, 2013 10:09 am

Ok, one last test. I uploaded a new test exe called "test2". Can you give that try? You'll just see a blank screen if it opens.

thanks!

Admin
Admin

Posts : 384
Join date : 2012-11-17

View user profile http://dawosc.forumotion.com

Back to top Go down

Re: Editor crashing at launch

Post  Llamatron on Sun Aug 11, 2013 10:12 am

Blank panel! \o/ tho dunno if I should rejoice if it takes that much stripping to stop crashing.

Llamatron

Posts : 10
Join date : 2013-08-10

View user profile

Back to top Go down

Re: Editor crashing at launch

Post  Admin on Sun Aug 11, 2013 10:16 am

That's actually good news...sort of.

The problem is the "UI library" that I'm using to display all the checkboxes, textboxes borders, etc, on the screen doesn't want to work on your computer for some reason.

I'll see if I can figure out an alternative for the editor UI. Hopefully, I'll be able to figure something in a few days.

I'll keep you posted.

Admin
Admin

Posts : 384
Join date : 2012-11-17

View user profile http://dawosc.forumotion.com

Back to top Go down

Re: Editor crashing at launch

Post  Llamatron on Sun Aug 11, 2013 10:35 am

If it's QT or wxWidgets there might be remains of their SDK somewhere on my system, and maybe that could be conflicting?

Llamatron

Posts : 10
Join date : 2013-08-10

View user profile

Back to top Go down

Re: Editor crashing at launch

Post  Admin on Sun Aug 11, 2013 10:45 am

Naw, it's neither of those. I've got it under control though Smile

Admin
Admin

Posts : 384
Join date : 2012-11-17

View user profile http://dawosc.forumotion.com

Back to top Go down

Re: Editor crashing at launch

Post  Admin on Tue Aug 13, 2013 6:38 pm

Ok, I've got a new editor for you to try. You can download the installer at:

http://markderrico.com/installer/

Fingers crossed!

Admin
Admin

Posts : 384
Join date : 2012-11-17

View user profile http://dawosc.forumotion.com

Back to top Go down

Re: Editor crashing at launch

Post  Llamatron on Wed Aug 14, 2013 1:00 am

This one works, thanks a lot Smile

Llamatron

Posts : 10
Join date : 2013-08-10

View user profile

Back to top Go down

Re: Editor crashing at launch

Post  Admin on Wed Aug 14, 2013 5:52 am

Great!

Admin
Admin

Posts : 384
Join date : 2012-11-17

View user profile http://dawosc.forumotion.com

Back to top Go down

Re: Editor crashing at launch

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum